AWS EC2 us-east-1 AWS Account performance degraded - CENTRAL-97357
Incident Report for Aurea Central
Resolved
A false alert was triggered for a past issue
Posted about 1 month ago. Jul 22, 2019 - 15:00 UTC
Identified
Starting April 21, 2019 21:38 GMT we are experiencing an incident: AWS Account performance degraded. This is affecting restricted set of customers.
We are working on the resolution and expect to have it resolved within the next 60 minutes.

We will provide an update every 30m or as soon as incident is resolved.
Posted about 1 month ago. Jul 22, 2019 - 14:30 UTC
This incident affected: AWS us-east-1 (AWS EC2 us-east-1).